Black screen at zap on newest martii-Neutrino-MP builds

Entwicklung
Antworten
Benny
Interessierter
Interessierter
Beiträge: 57
Registriert: Samstag 17. Mai 2014, 17:28
Sonstiges: GM990

Black screen at zap on newest martii-Neutrino-MP builds

Beitrag von Benny »

Greetings,

beginning from april (maybe, when martii starts rewriting/revising epl3, or this is just a coincidence), i noticed one annoying thing - some channels at zap/rezap became "blank" - no video and audio.
No any regularity with this - at some time it zaps normally, another time - blank screen. If, staying on this "black screen" channel, i run and stop "Picture viewer", "uPnP browser" or any media file - DVB video and audio begins playing normally. Log file attached below - i don't see any suspicious strings.

"Stream info" with this "black screen" shows LOCK, LEVELS, all PIDS, bitrate, but no video attributes.

Can this be fixed? Or, at least, can you point me how to debug this issue?

Thanks in advance.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Black screen at zap on newest martii-Neutrino-MP builds

Beitrag von martii »

I'd be surprised if there would be any correlation to my libeplayer3 changes.

I've never seen that issue (and am unable to reproduce it). Judging from your log output chances are that https://gitorious.org/neutrino-mp/marti ... c81323d80f might help.

However, this isn't even remotely regression-tested ...

Cheers,

martii
Benny
Interessierter
Interessierter
Beiträge: 57
Registriert: Samstag 17. Mai 2014, 17:28
Sonstiges: GM990

Re: Black screen at zap on newest martii-Neutrino-MP builds

Beitrag von Benny »

martii hat geschrieben:I've never seen that issue (and am unable to reproduce it).
Not sure about, but i personally do not using any "bouquets", ie my bouquets.xml and/or ubouquets.xml files always empty, only services.xml is used.
martii hat geschrieben:https://gitorious.org/neutrino-mp/marti ... c81323d80f might help.
This really helped! Maybe, zap time increased a bit, but annoying "black screen" gone away.
Gosh, i should write a post about it a month ago =)

Thank you, martii.
:up:

PS If you have some spare time, pls, look at date/time in "Box Info" - those strings can be properly formatted?
eg "18-05-2014 15:00" (taking into account timezone settings)
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Black screen at zap on newest martii-Neutrino-MP builds

Beitrag von martii »

Benny hat geschrieben:This really helped!
Cool, that's unexpected ;-)
Benny hat geschrieben:PS If you have some spare time, pls, look at date/time in "Box Info" - those strings can be properly formatted?
The date/time format conforms to ISO8601, and I have a strong tendency to leave it that way until he box info widget will be properly localized (if ever).

Cheers,

martii
Benny
Interessierter
Interessierter
Beiträge: 57
Registriert: Samstag 17. Mai 2014, 17:28
Sonstiges: GM990

Re: Black screen at zap on newest martii-Neutrino-MP builds

Beitrag von Benny »

martii hat geschrieben:leave it that way until he box info widget will be properly localized (if ever)
Ok, got it, thanks.
As for me, even now something like (%R %d-%m-%y) is more "human readable", but nevermind - i always can play around local repo to fit it for my needs =)
Benny
Interessierter
Interessierter
Beiträge: 57
Registriert: Samstag 17. Mai 2014, 17:28
Sonstiges: GM990

Re: Black screen at zap on newest martii-Neutrino-MP builds

Beitrag von Benny »

martii hat geschrieben: until he box info widget will be properly localized (if ever).
martii, did you mean under "localize" translation of text labels, or you planned to rewrite/revise this widget completely?

I've play a little with locales around boxinfo widget, not sure about "properly", but got something like this:
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Black screen at zap on newest martii-Neutrino-MP builds

Beitrag von martii »

Hi Benny,
Benny hat geschrieben:
martii hat geschrieben: until he box info widget will be properly localized (if ever).
martii, did you mean under "localize" translation of text labels, or you planned to rewrite/revise this widget completely?
I actually meant that I don't care enough.
I've play a little with locales around boxinfo widget, not sure about "properly", but got something like this:
Thanks. I've commited localization changes loosely based on your patch a couple of minutes ago.

Cheers,

martii
Antworten