Image für die OSmio+ 4K

Yocto/OE
Antworten
flk
Contributor
Beiträge: 292
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox
Kontaktdaten:

Image für die OSmio+ 4K

Beitrag von flk »

Auf dem Server liegt ab sofort ein Testimage für die Edision OSmio+ 4K Boxen. Ich habe die Box selbst und kann deshalb zumindest versichern, dass das Image bootet und auch schon gut benutzt werden kann. Es gibt noch ein paar lose Enden, aber zum testen in jedem Fall schon geeignet.

https://tuxbox-images.de/images/
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

thanks , now try ;)
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

after show Tuxwetter , not continue - box work but does not respond to the remote control , must reboot

PS: what activate send debug to console (putty RS232) ?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
flk
Contributor
Beiträge: 292
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von flk »

EnoSat hat geschrieben: Samstag 29. Februar 2020, 23:04 after show Tuxwetter , not continue - box work but does not respond to the remote control , must reboot
thank you ... i forgot to adjust remote device for plugins. will fix that tomorrow

To get neutrino log printed to console you just need to start journalctl in forground and follow mode for unit neutrino

connect with telnet/ssh

Code: Alles auswählen

journalctl -f -u neutrino
if you want to look at the entire neutrino log, use this command:

Code: Alles auswählen

journalctl -u neutrino
this opens a scrollable list starting with the oldest entries ... could be scrolled down to the latest ones

or you can write the log to a file like this:

Code: Alles auswählen

journalctl -u neutrino > /tmp/neutrino_log.txt
journald has some more really useful options like directly using grep on the output

https://www.freedesktop.org/software/sy ... alctl.html
flk
Contributor
Beiträge: 292
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von flk »

Remote control for plugins should be working again
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

Die Neuinstallation und Aktualisierung von Paketen ist über das online Update sowie den Paketmanager möglich.
online Update show Cant get update versioninfo

Packetmanger show
screenshot (1).png
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
flk
Contributor
Beiträge: 292
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von flk »

sorry, no package management right now. my server is runnign low on space

try using service->image-management->flash online image for update
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

maybe fixed link

Code: Alles auswählen

Mär 01 08:36:43 osmio4kplus neutrino.sh[252]: [neutrino] simple_display: open /dev/dbox/oled0: No such file or directory
Mär 01 08:36:44 osmio4kplus neutrino.sh[252]: [neutrino] simple_display: open /dev/dbox/oled0: No such file or directory
Mär 01 08:36:45 osmio4kplus neutrino.sh[252]: [neutrino] simple_display: open /dev/dbox/oled0: No such file or directory
Mär 01 08:36:45 osmio4kplus neutrino.sh[252]: * Couldn't open file //media/sda1/service/image/beta.txt
Mär 01 08:36:45 osmio4kplus neutrino.sh[252]: * Closing connection -1
Mär 01 08:36:49 osmio4kplus neutrino.sh[252]: [neutrino] simple_display: open /dev/dbox/oled0: No such file or directory
Mär 01 08:36:52 osmio4kplus neutrino.sh[252]: * Couldn't open file //media/sda1/service/image/beta.txt
Mär 01 08:36:52 osmio4kplus neutrino.sh[252]: * Closing connection -1
screenshot (2).png
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
flk
Contributor
Beiträge: 292
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von flk »

But for now this will only install the osmio4kplus image. That image will also run on osmio4k except lcd display. If you dont have osmio plus and want a working lcd display you will need to manually download and flash the osmio4k image

osmio4kplus has no working display at the moment
flk
Contributor
Beiträge: 292
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von flk »

screenshot.png
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

ahhh, i am search online in another menu :dash:
screenshot (3).png
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

Signal show 0 (zero) , Bitrate (yelow) not real
screenshot (4).png
screenshot (5).png
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

Problem with WLAN after reboot box. After flash (15032020) show correct devices in setup eth0,wlan0,wlp 1 s0
wlan0.jpg
but after reboot now show eth0,p2p0,wlp 1 s0 and box not connected to network
and if connect to wifi network, next services not work
ifup: failed to bring up eth0

Code: Alles auswählen

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2020.03.21 09:28:33 =~=~=~=~=~=~=~=~=~=~=~=
CPU 01
BCM72600000
PRID07260400
v1.29
RR:00000001
BFW
seclib-1.10
BBL v3.1.1
AVS init...
AVS init OK
AVS load:select_image: addr_offset: 00051000 part_offset: 00000000 bootStatus: 10002b00
AVS load_code offset =00051000
LOADED
AVS: overtemp mon ON

single board
select_image: addr_offset: 00056000 part_offset: 00000000 bootStatus: 302b2500
MEMSYS-ALT
SHMOO 03010100 BLD:memsys_3.1.1.0-0-g67b6027b5 HW:hpg0_b2p1 shmoo_ver:3.1.1.0
MCB: FLEX
AVS start:status=000000ff
STB: Current voltage=000003e4(996)
 temperature=0000f927(63783)
 PV=00000351(849)
 MV=000003e7(999)
CPU: Current voltage=000003e7(999)
 temperature=0000f927(63783)
 PV=0000032c(812)
 MV=000003e7(999)
AVS FW rev=30343978 [0.4.9.x]
OK
DDR0: !@ ffe07800 <= ffe06e9c MEMSYS-0 @ f1100000 OK
Sdram Scramble OTP = 0x00000001 
Sdram Scramble OK
select_image: addr_offset: 00020000 part_offset: 00000000 bootStatus: 2025252b
BFW load mode OTP = 0x0000000f 
bfw_hash_locked = 0x00000000 
BFW key3 OK, BFW load OK
BFW v4.3.5
INFO v00000002
COPY CODE... DONE
MICH: disable success
SSBL
SEC: jtag debug status: 000000af
PINMUX
CACHE FLUSH OK
CLR PSCI MEM @ 06400000 OK
INSTALL smm64@06400000 OK
MMU ON
CACHE FLUSH OK
_fbss  07062e38
_ebss  070653c8
_end   070653e8
HEAP @ 07100000
STACK @ 09200000
ARCH: CONFIG OK
CLR BSS 07062e38 to 070653c8 OK
CLR SRAM  OK
CACHE FLUSH OK
CPU CLKSET OK
GO!
PSCI: Init...
PSCI: config @ 0000000006402b40 cpus:2 cpu idx:0
cpu 0 state:5
cpu 1 state:0
PSCI: v0.2

    ,/    
  ,'/___, BOLT v1.29 v1.29-19 LOCAL BUILD
.'__  ,'  (2019-05-20 11:54:01 slartibartfast@magrathea.h2g2)
   /,'    Copyright (C) 2019 Broadcom
  /'      

Board: OSMIO4KPLUS
SYS_CTRL: product=72604, family=7260a0, strap=000001d9,00000011
otp @ 0xf0404030 = 0x000000e0: en_cr(0x00000060) en_testport(0x00000080) 
otp @ 0xf0404034 = 0x00804000: macrovision_disable(0x00800000) mtsif_enc_ctl_disable(0x00004000) 
RESET CAUSE: 0x000001 power_on (1 of 24 possible causes)
CS0: SFDP SPI, 4MB, 64kB blocks, 64kB erase block, 256B pages
RTS0: 0x21101004, 256 clients, ok
BOX MODE: 1
CPU: 2x B53 (64-bit) [420f1000] 1503 MHz
SCB: 388 MHz
SYSIF: 1002 MHz
DDR0 @ 1200MHz
SPLASH: starting
SPLASH BMEM init @ 80000000
SPLASH: Old format file in flash. Use splash_create_flash_file to create newer format.
Loaded BMP: W=720 H=576
SPLASH: audio not present
AVS: park check
AVS: temperature monitoring enabled
AVS: STB: V=0.998V, T=+63.783C, PV=0.849V, MV=0.999V, FW=30343978 [0.4.9.x]
AVS: CPU: V=0.999V, T=+63.783C, PV=0.812V, MV=0.999V

usb: resetting device on bus 1 hub 1 port 1


USB: New high speed device connected to bus 1 hub 1 port 1

usb: found Mass-Storage Device 0bc2:ab24

USBMASS: Unit 0 connected

*** Could not find a valid partition...status=00000000, ids=83000000!
dir: Could not init file system: File system not recognized
Executing STARTUP...
Loader:zimg Filesys:raw Dev:emmcflash0.kernel4 File:(null) Options:root=/dev/mmcblk1p9 rootfstype=ext4 rootwait
Reading up to 33554432 bytes from Image....
Starting program at 0x80000 (DTB @ 0x7628000)

64 bit PSCI boot...
PSCI: DTB @ 0000000007628000, Linux entry @ 0000000000080000
PWR_UP-CPU1 OK
BOOT64
ADDR-CPU1  0000000006402488 @ RDB: 20452008
ON-CPU1  00000002 @ 2020248c
GO-CPU1 @ 00000000009691e0
[*     ] A start job is running for Raise network interfaces (17s / 5min 9s)

[**    ] A start job is running for Raise network interfaces (18s / 5min 9s)

[***   ] A start job is running for Raise network interfaces (18s / 5min 9s)

[ ***  ] A start job is running for Raise network interfaces (19s / 5min 9s)

[  *** ] A start job is running for Raise network interfaces (19s / 5min 9s)

[   ***] A start job is running for Raise network interfaces (20s / 5min 9s)

[FAILED] Failed to start Raise network interfaces.
See 'systemctl status networking.service' for details.
[DEPEND] Dependency failed for Network.
[DEPEND] Dependency failed for :empty:.
[DEPEND] Dependency failed for NFS server and services.
[DEPEND] Dependency failed for NFS Mount Daemon.
[  OK  ] Reached target Network is Online.
         Starting Automounts filesystems on demand...
[  OK  ] Started minidlna server.
[  OK  ] Started NFS status monitor for NFSv2/3 locking..
         Starting Samba NMB Daemon...
         Starting Permit User Sessions...
         Starting Telnet daemon...
[  OK  ] Started UDP multicast to TCP (HTTP) relay proxy.
[  OK  ] Started eXtensible UPnP agent.
[  OK  ] Started Automounts filesystems on demand.
[  OK  ] Started Permit User Sessions.
[  OK  ] Started Telnet daemon.
[  OK  ] Started Serial Getty on ttyS0.
[  OK  ] Reached target Login Prompts.
[  OK  ] Stopped eXtensible UPnP agent.
[  OK  ] Started eXtensible UPnP agent.
[  OK  ] Stopped eXtensible UPnP agent.
[  OK  ] Started eXtensible UPnP agent.


 __  __         __         ___       __
 \ \/ /__  ____/ /____    / _ \___  / /____ __
  \  / _ \/ __/ __/ _ \  / ___/ _ \/  ´_/ // /
  /_/\___/\__/\__/\___/ /_/   \___/_/\_\\_, /
                                       /___/

tuxbox-neutrino 3.1.0 osmio4kplus ttyS0

osmio4kplus login: root

Password: 
#                                                                               
 

  ~ systemctl status networking.servicesystemctl


 networking.service - Raise network interfaces
     Loaded: loaded (/lib/systemd/system/networking.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Sat 2020-03-21 09:21:09 CET; 17s ago
       Docs: man:interfaces(5)
    Process: 246 ExecStart=/sbin/ifup -a --read-environment (code=exited, status=1/FAILURE)
   Main PID: 246 (code=exited, status=1/FAILURE)

Mär 21 09:21:09 osmio4kplus ifup[412]: Successfully initialized wpa_supplicant
Mär 21 09:21:09 osmio4kplus ifup[412]: Could not read interface wlan0 flags: No such device
Mär 21 09:21:09 osmio4kplus ifup[412]: nl80211: Driver does not support authentication/association or connect commands
Mär 21 09:21:09 osmio4kplus ifup[412]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mär 21 09:21:09 osmio4kplus ifup[412]: Could not read interface wlan0 flags: No such device
Mär 21 09:21:09 osmio4kplus ifup[412]: wlan0: Failed to initialize driver interface
Mär 21 09:21:09 osmio4kplus ifup[246]: ifup: failed to bring up wlan0
Mär 21 09:21:09 osmio4kplus systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
Mär 21 09:21:09 osmio4kplus systemd[1]: networking.service: Failed with result 'exit-code'.
Mär 21 09:21:09 osmio4kplus systemd[1]: Failed to start Raise network interfaces.
  ~
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
EnoSat
Neugieriger
Neugieriger
Beiträge: 8
Registriert: Samstag 22. September 2018, 20:15
Box 1: OSmio+ 4K
Box 2: Mutant HD51
Box 3: Dreambox
Box 4: Coolstream
Sonstiges: SAT & PC
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von EnoSat »

bug scan
if select DVB-T/T2-Auto box scan only DVB-T2 transponders, for DVB-T must manual or use edited terrestrial.xml
Eiche
Neugieriger
Neugieriger
Beiträge: 5
Registriert: Sonntag 4. Juli 2021, 12:15
Box 1: Zgemma H7
Box 2: Edision OS mio+

Re: Image für die OSmio+ 4K

Beitrag von Eiche »

None of released versions in june work on my two OSmio+ boxes. After flashing I only can see for a short moment the red blue "neutrino tuxbox" boot logo on the screen. Then the screen remains black and after one or two minute the box is rebooting.
dbt
Administrator
Beiträge: 2654
Registriert: Donnerstag 28. September 2006, 18:18
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von dbt »

Can you send a log?
released versions in june
Which version of June was it?
Otherwise, please initiate an update via the terminal:

Code: Alles auswählen

opkg update && opkg upgrade
Eiche
Neugieriger
Neugieriger
Beiträge: 5
Registriert: Sonntag 4. Juli 2021, 12:15
Box 1: Zgemma H7
Box 2: Edision OS mio+

Re: Image für die OSmio+ 4K

Beitrag von Eiche »

I don't get a log. I tested almost all versions from june. It worked once and when it booted up, the screen with the language choice was shown on the TV screen. But the remote control didn't respond.

Afterwards I reinstalled from USB the box with Pure2. When I installed tuxbox-neutrino from within pure2, in the terminal via ogfwrite to partition, it also caused the box to become unusable. After rebooting to tuxbox-neutrino the same issue: black screen and after some time a reboot. It only shows for a moment the boot logo (now pure2), then it switches to 720p (the TV indicates the change of resolution), but nothing on the TV screen and neither a progress bar on the front display, indicating the boot progress.

Within Pure2 on the multiboot partition screen, the tuxbox-neutrino OS is only shown with a date (2021-06-29), but not with the name. The entry for Pure 2 is: Pure2 (Date).
Eiche
Neugieriger
Neugieriger
Beiträge: 5
Registriert: Sonntag 4. Juli 2021, 12:15
Box 1: Zgemma H7
Box 2: Edision OS mio+

Re: Image für die OSmio+ 4K

Beitrag von Eiche »

Flashing Neutrino to boot partition 3 from a terminal connected to the box running pure2 – this is the output of ofgwrite:

Code: Alles auswählen

root@osmio4kplus:/tmp# ofgwrite -m3 ./osmio4kplus/
mkdir: can't create directory '/newroot': File exists

ofgwrite Utility v4.5.6
Author: Betacentauri
Based upon: mtd-utils-native-1.5.1 and busybox 1.24.1
Use at your own risk! Make always a backup before use!
Don't use it if you use multiple ubi volumes in ubi layer!

Flashing multiboot partition 3
Searching image files in ./osmio4kplus/ resolved to /var/volatile/tmp/osmio4kplus
Found kernel file: /var/volatile/tmp/osmio4kplus/kernel.bin
Found rootfs file: /var/volatile/tmp/osmio4kplus/rootfs.tar.bz2
Setting default parameter: Flashing kernel and rootfs
Found EXT4 rootfs
Found mounted /newroot
Found mounted /newroot
Found mounted /newroot
Found mounted /newroot
Found mounted /newroot
Found mounted /newroot
Found mounted /newroot
Found mountpoint for rootfs file: /var/volatile

Found /proc/mtd entries:
Device:   Size:     Erasesize:  Name:                   Image:
mtd0:     00200000  00010000    "flash0.bolt"     
mtd1:     00010000  00010000    "flash0.macadr"   
mtd2:     00010000  00010000    "flash0.nvram"    
mtd3:     00010000  00010000    "flash0.devtree"  
mtd4:     00400000  00010000    "flash0"          
Using kernel mtd device: 
Using rootfs mtd device: 
Read /proc/cmdline
Current rootfs is: /dev/mmcblk1p3
Current kernel is: 
Current root sub dir is: 

Execute: fdisk -l
Found valid GPT with protective MBR; using GPT

Using /dev/mmcblk1p6 as kernel device
Using /dev/mmcblk1p7 as rootfs device
Flashing currently not running image

Syncing filesystem
Mount to /oldroot_remount/ successful
Flashing kernel ...
Successfully flashed kernel!
Delete rootfs: rm -r -f /oldroot_remount/
rm: can't remove '/oldroot_remount': Device or resource busy
can't remove '/oldroot_remount': Device or resource busy
Untar: tar xf /var/volatile/tmp/osmio4kplus/rootfs.tar.bz2
Successfully flashed rootfs! Rebooting in 3 seconds...
Edit: code format
dbt
Administrator
Beiträge: 2654
Registriert: Donnerstag 28. September 2006, 18:18
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von dbt »

A new image is online. In the image from June 26th. was a bug in neutrino. Starting or stopping of Neutrino could fail.
Eiche
Neugieriger
Neugieriger
Beiträge: 5
Registriert: Sonntag 4. Juli 2021, 12:15
Box 1: Zgemma H7
Box 2: Edision OS mio+

Re: Image für die OSmio+ 4K

Beitrag von Eiche »

dbt hat geschrieben: Montag 5. Juli 2021, 11:35 A new image is online. In the image from June 26th. was a bug in neutrino. Starting or stopping of Neutrino could fail.
It still doesn't work for OSmio+. It just shows for a short moment the red "tuxbox" and blue "neutrino" (in 576i mode) on black background, then the screen turns plack, when it switches to 720p and after 2 minutes it reboots. When I plug out the hdmi cable, the TV indicates "no signal", when I plug it in again, it indicates "720p Eingangssignal". So it must be somehow running, but there is no active network. SSH is not possible

I've tested one image from February, one from May and almost all from June.

What's the first menu coming up on the screen and what keys could I press to change the video resolution? When I press some keys, the green LED on the receiver starts responding to input from the remote control. And then the box does not reboot.

Unfortunately there is neither support for the matrix display on the receiver. Is there hope, that this will be supported?
dbt
Administrator
Beiträge: 2654
Registriert: Donnerstag 28. September 2006, 18:18
Kontaktdaten:

Re: Image für die OSmio+ 4K

Beitrag von dbt »

I can't really say something more about it. Unfortunately, I don't have such a box, but as far as I know @flk owns an osmio and prepared the things for it. I don't know if he can say something about that. He was not here for a long time.
Eiche
Neugieriger
Neugieriger
Beiträge: 5
Registriert: Sonntag 4. Juli 2021, 12:15
Box 1: Zgemma H7
Box 2: Edision OS mio+

Re: Image für die OSmio+ 4K

Beitrag von Eiche »

In the meantime I could also test it with the OS Mio (without +). Neither on this box the provided images boot up to a set up screen. The screen remains dark and after a minute or two it reboots.

I assume it might have to do with the different flash size of 8 GB (other pricy boxes like VU+ still provide 4 GB only) or a different partition layout of this box.
Antworten