Probleme mit LIRC und Panasonic DMR-HS2

uPNP, VLC, LIRC, IR, Automatisierung, Web-API, NAS, RS232, etc..
Mottenstein
Neugieriger
Neugieriger
Beiträge: 6
Registriert: Mittwoch 27. April 2005, 19:23

Probleme mit LIRC und Panasonic DMR-HS2

Beitrag von Mottenstein »

Hallo,

ich versuche jetzt schon einige Abende die Steuerung meines DVD-Recorders (Panasonic DMR-HS2 mit Fernbedienung EUR7615KD0) mit LIRC hinzubekommen. Aber irgendwas scheine ich falsch zu machen!

Ich habe mir das allgemeine VCR-File von der LIRC-Homepage gezogen. In einigen Beiträgen hier wird gesagt, dass die Grundfunktionen auf allen Panasonic-Recorders dieselben IR-Codes haben.

Des Weiteren hab ich dann noch zum Testen die Datei "sbon.lirc" mit folgendem Inhalt angelegt:


# Wartezeit eine Sekunde
WAIT 1000

# Name VCR einschalten. Das Signal wird eine Sekunde lang gesendet
PLAY 1000


Beide Dateien hab ich dann ins Verzeichnis /var/tuxbox/config/lirc/ kopiert, die Permission der Files auf 755 gesetzt und die Box neu gebootet.

Den DVD-Recorder hab ich bei einem aufgenommenen Programm in den Pausen-Modus versetzt. Eigentlich sollte ja das Programm des Recorders weiter abgespielt werden, wenn ich die dbox in den Standby versetze. Aber leider tut sich gar nichts :cry:

Hoffe, jemand von euch kann mir helfen...

Vielen Dank im voraus!
gurgel
Tuxboxer
Tuxboxer
Beiträge: 2473
Registriert: Dienstag 8. Oktober 2002, 20:06

Beitrag von gurgel »

hast du die Datei auch im ACSII-Modus übertragen?
Mottenstein
Neugieriger
Neugieriger
Beiträge: 6
Registriert: Mittwoch 27. April 2005, 19:23

Beitrag von Mottenstein »

Ja, hab die Dateien im ASCII-Mode übertragen! Vielleicht liegts ja daran, dass die Steuerdatei nicht zu meinem DVD-Recorder passt. Hat vielleicht jemand eine passende Datei?
gurgel
Tuxboxer
Tuxboxer
Beiträge: 2473
Registriert: Dienstag 8. Oktober 2002, 20:06

Beitrag von gurgel »

Mottenstein
Neugieriger
Neugieriger
Beiträge: 6
Registriert: Mittwoch 27. April 2005, 19:23

Beitrag von Mottenstein »

Danke für den Tipp... leider klappts damit auch nicht, obwohl sich ja die Fernbedienungen sehr ähnlich sein müssten. Insofern kann man vielleicht sagen, dass es doch nicht an der Steuerdatei liegt.

Was könnte ich denn noch falsch gemacht haben?
Mottenstein
Neugieriger
Neugieriger
Beiträge: 6
Registriert: Mittwoch 27. April 2005, 19:23

Beitrag von Mottenstein »

Kann man vielleicht irgendwie testen, ob die dbox ein IR-Signal sendet? Gibt es irgendwo eine Protokolldatei?
thomasn1985
Interessierter
Interessierter
Beiträge: 98
Registriert: Sonntag 3. Oktober 2004, 10:03

Beitrag von thomasn1985 »

halt ma nen digitalen cmacorder davoir, dann siehste es, geht auch mit ner handykamera ;)
Lebe den Augenblick, denn er ist Einzigartig!
Mottenstein
Neugieriger
Neugieriger
Beiträge: 6
Registriert: Mittwoch 27. April 2005, 19:23

Beitrag von Mottenstein »

Ok, da haben wir den Fehler... das Mistding sendet nichts!

Meine lircd.conf sieht so aus:


#
# this config file was automatically generated
# using WinLIRC 0.6.5 (LIRC 0.6.1pre3) on Tue Feb 03 19:10:34 2004
#
# contributed by
#
# brand: panasonic_dvd
# model:
# supported devices:
#

begin remote

name panasonic_dvd
bits 16
flags SPACE_ENC
eps 25
aeps 100

header 3554 1641
one 503 344
zero 503 1213
ptrail 503
pre_data_bits 32
pre_data 0xBFFBF2F7
gap 74344
toggle_bit 0


begin codes
POWER_DVD 0x0000000000004346
REC 0x000000000000EFEA
DIRECT_TV_REC 0x0000000000006560
SHOWVIEW 0x0000000000000104
NO_1 0x000000000000F7F2
NO_2 0x0000000000007772
NO_3 0x000000000000B7B2
NO_4 0x0000000000003732
NO_5 0x000000000000D7D2
NO_6 0x0000000000005752
NO_7 0x0000000000009792
NO_8 0x0000000000001712
NO_9 0x000000000000E7E2
NO_0 0x0000000000006762
NO_DIGITS 0x0000000000006E6B
CH_UP 0x000000000000D3D6
CH_DOWN 0x0000000000005356
CANCEL 0x0000000000003E3B
SKIP_BACK 0x0000000000006D68
SKIP_FORWARD 0x000000000000ADA8
SEARCH_BACK 0x000000000000DFDA
SEARCH_FORWARD 0x0000000000005F5A
STOP 0x000000000000FFFA
PAUSE 0x0000000000009F9A
PLAY 0x000000000000AFAA
UP 0x0000000000005E5B
LEFT 0x0000000000001E1B
RIGHT 0x000000000000EEEB
DOWN 0x0000000000009E9B
ENTER 0x000000000000BEBB
TOPMENU 0x0000000000002623
PLAYLIST_MENU 0x000000000000FEFB
FUNCTIONS 0x0000000000001510
PROG_CHECK 0x000000000000C1C4
TIMER 0x000000000000E1E4
MANUAL_SKIP 0x000000000000CDC8
TIME_SLIP 0x0000000000002D28
F_REC 0x0000000000001C19
REC_MODE 0x0000000000007570
FRAME_LEFT 0x0000000000004F4A
FRAME_RIGHT 0x000000000000CFCA
INPUT_SELECT 0x000000000000F5F0
STATUS 0x0000000000000500
AV_LINK 0x000000000000C6C3
DISPLAY 0x000000000000B6B3
ERASE 0x000000000000DDD8
AUDIO 0x0000000000003336
POSITION_MEMORY 0x0000000000009D98
end codes

end remote


Dann hab ich noch folgendes in der sbon.lirc und sboff.lirc stehen (nur zum Testen natürlich):


WAIT 1000
POWER_DVD 1000
WAIT 1000
POWER_DVD 1000
WAIT 1000
POWER_DVD 1000
WAIT 1000
POWER_DVD 1000
WAIT 1000


Sieht einer von euch nen Fehler?

Ich hab übrigens das YADI-Release vom 02.10.2004 auf meiner Box. Das müsste doch LIRC automatisch starten, oder?
MOhlmann
Einsteiger
Einsteiger
Beiträge: 205
Registriert: Montag 19. April 2004, 20:09

Beitrag von MOhlmann »

Hallo, ändere mal die sbon.lirc so ab

Code: Alles auswählen

WAIT 1000 
panasonic_dvd POWER_DVD 1000


Gruß Michael
Mottenstein
Neugieriger
Neugieriger
Beiträge: 6
Registriert: Mittwoch 27. April 2005, 19:23

Beitrag von Mottenstein »

Ja, das isses... Hätte ich auch selbst drauf kommen können! 1000 Dank!

Zurück zu „Integration“