Spark (div. Kleinigkeiten)

Entwicklung
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

martii hat geschrieben:
schufti hat geschrieben:°) dem TS-Player (Vorspulen über Anfang hängt box)
kann ich nachvollziehen, aber zumindest von meiner Seite noch keine Fehlerbehebung da.
Seit eben hoffentlich behoben.
schufti
Einsteiger
Einsteiger
Beiträge: 352
Registriert: Freitag 20. August 2004, 22:33

Re: Spark (div. Kleinigkeiten)

Beitrag von schufti »

Danke :up: martii.

weitere Info zum Menüpositionsproblem:

wenn die andere Position mal eingetellt ist, geht es normal, bloß während dem Umstellen gibts Brösel.
Öfter Wechseln kann ich wenn 1080er Auflösung gewählt ist, bei 720er krachts beim 2-3 mal.

log sieht z.B. so aus (das war ein ganz schlimmer mit reboot):

Code: Alles auswählen

COsdSetup::exec:: action
CLCD::ShowText: [Settings]
CLCD::ShowText: [Menu position top right]
CLCD::ShowText: [Menu position bottom left]
CLCD::ShowText: [Settings]
[neutrino] fb::blitRect: y + h > yRes![  130.232000] 
Unable to handle kernel paging request at virtual address cc00153c
[  130.232000] pgd = 87eb8000
[  130.232000] [cc00153c] *pgd=00000000
[  130.232000] Oops: 0000 [#1]
[  130.232000] last sysfs file: /sys/devices/virtual/input/input2/event2/dev
ich weiß nicht, was da noch alles geschieht. jedenfalls ist dann auch die Tastenerkennung der FB gestört (alle Tastendrücke werden x-fach registriert) und das Frontdisplay "scrollt" auch in Zeitlupe.

mein Netzwerkproblem habe ich momentan so gelöst, dass ich in start_neutrino ein showmount auf den NAS-server mache, damit läuft es 100%ig. Da ja schon der mountbefehl fehlschlägt, greift der sectionsd einfach ins leere; da hilft auch die "hard" option nicht, wenn nichts gemounted ist. Interessanter weise ist der mount aber später doch existent; mach der CFSmounter retries?
Jedenfalls habe ich für mich mal den CFSmounter Aufruf weit vor den sectionsd Start verlegt, für mich logischer als weit danach ....
schufti
Einsteiger
Einsteiger
Beiträge: 352
Registriert: Freitag 20. August 2004, 22:33

Re: Spark (div. Kleinigkeiten)

Beitrag von schufti »

äähhh, Frage:
hat sich bei den Aufnahmetimern etwas geändert oder habe ich eine Einstellung übersehen?

Ich bin mir jedenfalls sicher, dass sich die Box bisher nach Timer-Aufnahmen (auch wenn bei Timerstart in Betrieb) nicht automatisch abgeschalten hat ...

schönes WE,
schufti
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

schufti hat geschrieben:Ich bin mir jedenfalls sicher, dass sich die Box bisher nach Timer-Aufnahmen (auch wenn bei Timerstart in Betrieb) nicht automatisch abgeschalten hat ...
Zunächst wäre es ja schon hilfreich zu wissen, welchen Tree Du baust. Sonst sucht Seife nach Bugs, die bei ihm nicht da sind.

Falls mein Tree, was ich aus verschiedenen Gründen impliziere: Ich hatte da versehentlich die Abfrage aktiviert, ob Wakeup aus Standby erfolgte. Geht jetzt wieder.
schufti
Einsteiger
Einsteiger
Beiträge: 352
Registriert: Freitag 20. August 2004, 22:33

Re: Spark (div. Kleinigkeiten)

Beitrag von schufti »

danke für den Hinweis, ist klar; werde ich zukünftig machen.
jedenfalls wieder besten Dank für die rasche Korrektur!

konntest du das Problem mit der Menüposition nachvollziehen?
Ich versuche jetzt mal ein build ohne graphlcd ....

(btw. was ist in OSD die Einstellung "big windows", da sehe ich keinen Unterschied.)
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

Hi Schufti,

nein, bzgl. der Menüposition konnte ich keine gravierenden Probleme feststellen. Hab' nur die blitRect()-Fehler gesehen, aber die sind harmlos (schaut aus, als wäre der Schatten der Fenster da außerhalb der regulären Größe, die FB-Routinen korrigieren das dann aber).

GraphLCD dürfte damit nichts zu tun haben. Wenn Du ohne GraphLCD testen willst, reicht es aber auch völlig, das im Menü zu deaktivieren.

"Big Windows": EPG-Anzeige, glaube ich.
schufti
Einsteiger
Einsteiger
Beiträge: 352
Registriert: Freitag 20. August 2004, 22:33

Re: Spark (div. Kleinigkeiten)

Beitrag von schufti »

ok, auch ohne graphlcd das selbe Verhalten.
k.A. wie ich das vorzeigen könnte, ausser ein Video davon zu drehen ...

Edit: 1:
konkerter Vorgang: im Menü Settings/osd/menüposition drücke ich 2-3x ok. dabei springt das Menü 1-2x herum, dann knarzt es im Lautsprecher, Bild und Ton fallen aus und das Zeitlupenverhalten beginnt. drücke ich dann zb. exit oder ok, passiert vorerst nichts, dann blinkt kurz die LED und das Menü blitzt (bei ok an verschiedenen anderen Positionen) mahrfach unkontrolierbar kurz auf, die Anzeige allerdings läuft schon in Zeitlupe.
hat es Sinn, dir meine neutrino.conf zu schicken?

interessant ist dabei: die Menüposition ist dann immer in der neutrino.conf abgespeichert obwohl ich nach dem Wechsel ja nichtmal zum Abspeichern komme.
Alles andere läuft dann nurmehr in Zeitlupe, auch z.B. telnet oder Webinterface

Der Process Interocitor 1 läuft dann mit 99,x% CPU ...

jetzt teste ich das mal mir orig seife build
Edit: 1: selbes Verhalten, wobei es einen Ticken mehr bedienbar bleibt ...

Edit: 2: ok, Asche auf mein Haupt: hätte ich eher testen sollen: mit ner jugfräulichen neutrino.conf geht es plötzlich. k.A. was da drin nicht ok ist. Mag das wer analysieren? (ich befürchte: nööö :lol: )

Edit: 3: ok, lokalisiert: das tritt auf, wenn man den OSD Bereich bis (knapp?) an die Auflösungsgrenzen setzt. Ist also doch wohl irgendeine Unsauberkeit in den Grafikroutinen.
schufti
Einsteiger
Einsteiger
Beiträge: 352
Registriert: Freitag 20. August 2004, 22:33

Re: Spark (div. Kleinigkeiten)

Beitrag von schufti »

@martii: neues Problem im Fileplayer (im ts-player ok)

Code: Alles auswählen

[neutrino] CSectionsdClient::EVT_GOT_CN_EPG
Neutrino: apid name= deu (German) pid= D00
Neutrino: pref_found -1 pref_ac3_found -1 ac3_found -1
[neutrino] CSectionsdClient::EVT_GOT_CN_EPG
CMoviePlayerGui::SelectFile: full_name [/mnt/nfs/streams/test.ts] file_name [test.ts]
Startplay at 0 seconds
CMoviePlayerGui::handleMovieBrowser: reset vars
CCam::MakeMask: demuxes 0:0:0 old mask 1 new mask 0
CCam::setCaPmt cam a782d0 source 0 camask 0 update yes
StopPlayBack: standby 1 forced 0
TuxTxt stopping subtitle thread ...
[dvb-sub] paused
playback_libeplayer3.cpp:Open - PlayMode=PLAYMODE_FILE
Output
IS FILE PLAYER: true
Segmentation fault
Neutrino exited with exit code 139
[neutrino] frameBuffer Instance created
libstb-hal debug options can be set by exporting HAL_DEBUG.
The following values (or bitwise OR combinations) are valid:
        component: audio   0x01
        component: video   0x02
        component: demux   0x04
        component: play    0x08
        component: power   0x10
        component: init    0x20
        component: ca      0x40
        component: record  0x80
        all components:    0xff
[LT:00000000:init  ] init_td_api begin, initialized=0, debug=0x00
[LT:00000000:init  ] init_td_api: lircd pidfile present, not starting input thread
[LT:00000000:init  ] init_td_api end
FB: 1280x720x32 line length 5120.
12288k video mem
[neutrino start] 1809  ->     0 ms
im orig. Seife noch nicht getestet.

@Seife: danke für Korrektur von Menüposition Fehler :up:
dietmarw
Contributor
Beiträge: 1833
Registriert: Mittwoch 10. April 2002, 14:39

Re: Spark (div. Kleinigkeiten)

Beitrag von dietmarw »

@seife

spricht etwas dagegen, das du die verschiedenen lircd.conf.09_00_xx aus martiis build in deinen übernimmst?
Download Bereiche für DBox2, TD und Spark Distributionen
http://dietmarw.polsum.net
http://dietmarw.trale.de (r.i.p.)
schufti
Einsteiger
Einsteiger
Beiträge: 352
Registriert: Freitag 20. August 2004, 22:33

Re: Spark (div. Kleinigkeiten)

Beitrag von schufti »

Fileplayer-Problem:

seife build von heute: ok
martii build von heute: nok
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

schufti hat geschrieben:Fileplayer-Problem:

seife build von heute: ok
martii build von heute: nok
Ist behoben (vermutlich -- noch nicht getestet).
schufti
Einsteiger
Einsteiger
Beiträge: 352
Registriert: Freitag 20. August 2004, 22:33

Re: Spark (div. Kleinigkeiten)

Beitrag von schufti »

@martii: sieht gut aus! danke :up:
WerN
Interessierter
Interessierter
Beiträge: 27
Registriert: Samstag 2. Juni 2012, 18:35

Re: Spark (div. Kleinigkeiten)

Beitrag von WerN »

Hallo,

im Movieplayer über meine FritzBox NAS werden keine Umlaute angezeigt. D.h. das der Dateiname ab dem Umlaut abgeschnitten ist. Gibt es 'ne Möglichkeit das zu fixen?
@martii: Ist es möglich im Pearl Display im Standby eine große Uhr anzuzeigen?

Danke, WerN
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

WerN hat geschrieben:@martii: Ist es möglich im Pearl Display im Standby eine große Uhr anzuzeigen?
Zunächst einmal geht die Uhranzeige im Standby jetzt prinzipiell wieder (hatte ich vergessen, Standby verwende ich nicht).

Bgzl. der Größe der Zeitanzeige: Mal schauen. Aktuell ist die in Standby und in Betrieb identisch, und ich tendiere dazu, das so zu lassen.
WerN
Interessierter
Interessierter
Beiträge: 27
Registriert: Samstag 2. Juni 2012, 18:35

Re: Spark (div. Kleinigkeiten)

Beitrag von WerN »

Kein problem. Danke trotzdem.

WerN
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

WerN hat geschrieben:@martii: Ist es möglich im Pearl Display im Standby eine große Uhr anzuzeigen?
Ich hab das mal eingebaut. Außerdem können nun statt der Sender-Namen auch Logos angezeigt werden, sofern vorhanden.
pixbox
Interessierter
Interessierter
Beiträge: 54
Registriert: Mittwoch 25. Juli 2012, 01:16

Re: Spark (div. Kleinigkeiten)

Beitrag von pixbox »

martii hat geschrieben: Ich hab das mal eingebaut. Außerdem können nun statt der Sender-Namen auch Logos angezeigt werden, sofern vorhanden.
funktioniert bestens mit den E2 Picons :up:
WerN
Interessierter
Interessierter
Beiträge: 27
Registriert: Samstag 2. Juni 2012, 18:35

Re: Spark (div. Kleinigkeiten)

Beitrag von WerN »

Hallo,

@ martii: Danke für das implementieren der Uhrzeitanzeige im Standby im Pearl Display.
Leider schaltet er im Standby aber nicht auf die Uhrzeitanzeige. In den Einstellungen wenn ich die größe der Uhrzeit vornehme, sieht man aber die Uhrzeit im Display.

Danke,
WerN
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

WerN hat geschrieben: Leider schaltet er im Standby aber nicht auf die Uhrzeitanzeige. In den Einstellungen wenn ich die größe der Uhrzeit vornehme, sieht man aber die Uhrzeit im Display.
Bei mir geht's. Du redest schon von Standby, nicht von Deep Standby?
WerN
Interessierter
Interessierter
Beiträge: 27
Registriert: Samstag 2. Juni 2012, 18:35

Re: Spark (div. Kleinigkeiten)

Beitrag von WerN »

Ich meine schon den Standby. Im Deepstandby wird das Display ausgeschaltet (wie es auch sein soll).
Im Standby bleibt weiterhin die Anzeige des Senders etc. War bei mir schon immer so.
Getestet mit dietmarw's build von heute früh.

Gruß,
WerN
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

WerN hat geschrieben:Getestet mit dietmarw's build von heute früh.
Ich würde zwar raten, dass das aktuell ist, aber kannst Du's mal mit dem Binary im Anhang probieren? Entpacken, nach /bin/ schieben, Neutrino neu starten.

(Edit: Binary wieder entfernt)
Zuletzt geändert von martii am Montag 13. August 2012, 19:14, insgesamt 1-mal geändert.
WerN
Interessierter
Interessierter
Beiträge: 27
Registriert: Samstag 2. Juni 2012, 18:35

Re: Spark (div. Kleinigkeiten)

Beitrag von WerN »

Danke für die bin. Leider hat es nach einer ein- ausschaltorgie nur einmal funktioniert.
Keine Ahnung woran es liegen könnte. Habe sogar ein anderes Pearl LCD versucht.

Gruß,
WerN
martii
Einsteiger
Einsteiger
Beiträge: 217
Registriert: Donnerstag 14. Juni 2012, 08:39

Re: Spark (div. Kleinigkeiten)

Beitrag von martii »

WerN hat geschrieben:Danke für die bin. Leider hat es nach einer ein- ausschaltorgie nur einmal funktioniert.
Ich rate mal ... Du hast OSD-Mirroring aktiv, also Menü-Anzeige auf dem Pearl-Display? Dann ging's bis eben tatsächlich nicht, Asche auf mein Haupt. Gefixtes Binary im Anhang.

(Edit: Binary entfernt.)
Zuletzt geändert von martii am Dienstag 14. August 2012, 21:33, insgesamt 1-mal geändert.
WerN
Interessierter
Interessierter
Beiträge: 27
Registriert: Samstag 2. Juni 2012, 18:35

Re: Spark (div. Kleinigkeiten)

Beitrag von WerN »

Bist ein Schatz! ;)
Funktioniert nun bestens. Hatte in der Tat die Menüanzeige aktiv. Benutze nämlich die box auch als Internetradio, und mithilfe des Displays muss ich nicht mal den TV einschalten. Auch die fehlerhafte Darstellung der Umlaute im Mediaplayer konnte ich durch umstellen von UTF8 auf ISO beheben.
Also nochmals vielen Dank.

Gruß,
WerN