Neutrino-MP für Coolstream

Fremd-Buildsysteme
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Neutrino-MP für Coolstream

Beitrag von flk »

Hallo,

ich versuche gerade Neutrino-MP für meine Coolstream zu bauen. Läuft auch relativ weit durch. Ich hatte einen Abbruch, den ich dadurch beheben konnte, dass ich in /buildsystem-cs/source/neutrino-mp/lib/libcoolstream/hardware_caps.h '#include "string.h' eingefügt habe. Aber jetzt ...

Code: Alles auswählen

make[5]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src/nhttpd'
make[4]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src/nhttpd'
make[4]: Betrete Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src'
  CXX    neutrino_menue.o
  CXX    neutrino.o
  CXXLD  neutrino
neutrino.o: In function `get_hwcaps':
...
neutrino_menue.o:/home/neutrino/buildsystem-cs/source/neutrino-mp/lib/libcoolstream/hardware_caps.h:43: first defined here nhttpd/tuxboxapi/coolstream/libnhttpd_tuxboxapi.a(controlapi.o): In function `get_hwcaps':
/home/neutrino/buildsystem-cs/source/neutrino-mp/lib/libcoolstream/hardware_caps.h:43: multiple definition of `get_hwcaps'
neutrino_menue.o:/home/neutrino/buildsystem-cs/source/neutrino-mp/lib/libcoolstream/hardware_caps.h:43: first defined here ../lib/libtuxtxt/libtuxtxt.a(tuxtxt.o): In function `get_hwcaps':
/home/neutrino/buildsystem-cs/source/neutrino-mp/lib/libcoolstream/hardware_caps.h:43: multiple definition of `get_hwcaps'
neutrino_menue.o:/home/neutrino/buildsystem-cs/source/neutrino-mp/lib/libcoolstream/hardware_caps.h:43: first defined here driver/libneutrino_driver.a(record.o): In function `CRecordInstance::GetStatus()':
record.cpp:(.text+0x788): undefined reference to `cRecord::GetStatus()'
driver/libneutrino_driver.a(record.o): In function `CRecordInstance::Start(CZapitChannel*)':
record.cpp:(.text+0x970): undefined reference to `cRecord::Start(int, unsigned short, unsigned short*, int, unsigned long long)'
zapit/src/libzapit.a(capmt.o): In function `CCam::sendCaPmt(unsigned long long, unsigned char*, int)':
/home/neutrino/buildsystem-cs/source/neutrino-mp/src/zapit/src/capmt.cpp:139: undefined reference to `cCA::SendCAPMT(unsigned long long, unsigned char, unsigned char, unsigned char const*, unsigned int, unsigned char const*, unsigned int)'
zapit/src/libzapit.a(capmt.o): In function `CCamManager::SetMode(unsigned long long, CCamManager::runmode, bool, bool)':
/home/neutrino/buildsystem-cs/source/neutrino-mp/src/zapit/src/capmt.cpp:254: undefined reference to `cCA::GetCAIDS(std::vector<unsigned short, std::allocator<unsigned short> >&)'
collect2: error: ld returned 1 exit status
make[4]: *** [neutrino] Fehler 1
make[4]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src'
make[3]: *** [all-recursive] Fehler 1
make[3]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src'
make[2]: *** [all-recursive] Fehler 1
make[2]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp'
make[1]: *** [all] Fehler 2
make[1]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp'
make: *** [neutrino-pkg] Fehler 2
Wer kann mir weiterhelfen ?

Edit: edit by doc
bitte bbcode benutzen

alles klar, ist gespeichert ;)
Zuletzt geändert von flk am Samstag 10. November 2012, 21:07, insgesamt 1-mal geändert.
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

Hm. Ich muss mir erst mal eine Buildumgebung machen, mit der ich für coolstream bauen kann, dann kann ich mir das anschauen. Aber ich kann es halt dann nicht testen.
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Ich weiss ja, das Coolstream nicht gerade deine Lieblingsplattform ist. Wäre trotzdem klasse, wenn du dir den Aufwand machen würdest. Eine Alternative zur Original Coolstream Firmware wär schon schön ... Zum Testen würd ich mich auch sofort bereit erklären. Wenn deine Prioritäten anders liegen, wär das aber auch ok .... bin dir sehr dankbar für deine Arbeit hier !
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

naja, es wäre z.B. schon hilfreich, wenn sich jemand drum kümmern würde, dass das buildsystem dafür funktioniert. Ich musste erst mal das umgebaute git-zeugs reinfriemeln, die 3 Stunden hätte ich auch dafür verwenden können, dein Buildproblem zu fixen...
dbt
Administrator
Beiträge: 2675
Registriert: Donnerstag 28. September 2006, 18:18

Re: Neutrino-MP für Coolstream

Beitrag von dbt »

Ich hab mir das soweit schon angepasst, allerdings ziehe ich die Neutrinoquellen direkt aus dem CST-GIT. Wenn es das ist, sollten die Anpassungen schon ausreichen. Aber nicht dass ich jetzt falsch interpretiere, Neutrino-MP verwende ich auch nur für die !Arm-Plattformen. Wäre aber nicht übel, wenn das auch mit MP ginge.
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

Also kompilieren sollte es nun. Ob's funktioniert... :-)
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Code: Alles auswählen

make[5]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src/nhttpd'
make[4]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src/nhttpd'
make[4]: Betrete Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src'
  CXX    neutrino_menue.o
  CXX    neutrino.o
  CXXLD  neutrino
driver/libneutrino_driver.a(record.o): In function `CRecordInstance::GetStatus()':
/home/neutrino/buildsystem-cs/source/neutrino-mp/src/driver/record.cpp:135: undefined reference to `cRecord::GetStatus()'
driver/libneutrino_driver.a(record.o): In function `CRecordInstance::Start(CZapitChannel*)':
/home/neutrino/buildsystem-cs/source/neutrino-mp/src/driver/record.cpp:180: undefined reference to `cRecord::Start(int, unsigned short, unsigned short*, int, unsigned long long)'
zapit/src/libzapit.a(capmt.o): In function `CCam::sendCaPmt(unsigned long long, unsigned char*, int)':
/home/neutrino/buildsystem-cs/source/neutrino-mp/src/zapit/src/capmt.cpp:139: undefined reference to `cCA::SendCAPMT(unsigned long long, unsigned char, unsigned char, unsigned char const*, unsigned int, unsigned char const*, unsigned int)'
zapit/src/libzapit.a(capmt.o): In function `CCamManager::SetMode(unsigned long long, CCamManager::runmode, bool, bool)':
/home/neutrino/buildsystem-cs/source/neutrino-mp/src/zapit/src/capmt.cpp:254: undefined reference to `cCA::GetCAIDS(std::vector<unsigned short, std::allocator<unsigned short> >&)'
collect2: error: ld returned 1 exit status
make[4]: *** [neutrino] Fehler 1
make[4]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src'
make[3]: *** [all-recursive] Fehler 1
make[3]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp/src'
make[2]: *** [all-recursive] Fehler 1
make[2]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp'
make[1]: *** [all] Fehler 2
make[1]: Verlasse Verzeichnis '/home/neutrino/buildsystem-cs/build_tmp/neutrino-mp'
make: *** [neutrino-pkg] Fehler 2
Bei mir hängts noch
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

alte libs würde ich vermuten.
doc
Contributor
Beiträge: 1623
Registriert: Donnerstag 10. Januar 2002, 20:03

Re: Neutrino-MP für Coolstream

Beitrag von doc »

Würde ich so auch vermuten, vermutlich ist die libcoolstream-mt.so älter wie 5bd3d58.
Ich habe ein wenig mit git bisect gespielt. Ist in diesem Fall ein wenig verwirrend da git bisect genau anders herum arbeitet wie hier benötigt (man sucht eine letzte noch "gute" Version, hier sucht man die erste "gute" Version).

Folgende Versionen sind im Git Repo bei CST vorhanden.
als Basis

Code: Alles auswählen

$ git log --pretty=oneline --abbrev-commit

Code: Alles auswählen

HEAD    1  9630e8a 2.10 drivers for  2.6.35.14-nevis
HEAD~1  2  b3b5e29 2.10 drivers for  2.6.39.4-nevis
HEAD~2  3  eb6ffc2 2.10 drivers for 2.6.26.8-nevis
HEAD~3  4  2e9238c libs/libcoolstream-mt.so: change place to send CI CA_MESSAGE_MSG_INIT_OK message, should fix black screen with CI on boot
HEAD~4  5  ed28d74 driver update
HEAD~5  6  9f05cf4 libs: experimental! add limited support to playback file been recorded by other box (i.e. nfs) playback must be started when file > 10mb and record time > 20 seconds, new libs must HEAD~6  7  be on both boxes
HEAD~7  8  0b21c28 drivers for kernel version 2.6.34.13
HEAD~8  9  3b5ca1b 2.6.39.4 drivers update
HEAD~9  10 5bd3d58 libs: fix crash on record stop
HEAD~10 11 577d586 Update for image 2.09
HEAD~11 12 3798bbc restore stable libs
HEAD~12 13 e872330 start branch for public testing
HEAD~13 14 fce3742 testing/ dir with support for multi-record of the same channel
HEAD~14 15 b49d833 add new lib
HEAD~15 16 9ff0dc3 add new drivers
HEAD~16 17 94c3c7f Update to 2.08 drivers and library
HEAD~17 18 c3966db update for image 2.07
HEAD~18 19 7b4afaf Initial commit, drivers and libs from svn
Mit git bisect und etwas Logik kann man nun suchen ab welcher Revision ein Symbol in der entsprechenden Lib vorhanden ist.

Zunächst sucht man sich in der Symboltabelle der Lib das enstprechende Symbol, --> undefined reference to `cRecord::GetStatus()' in etwa so etwas.

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [master] $ readelf -a libs/lib*.so | grep cRecord | grep GetStatus
   468: 000345fc    88 FUNC    GLOBAL DEFAULT   10 _ZN7cRecord9GetStatusEv
Nun kann man mit git bisect starten.

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [master] $ git bisect start
Die aktuelle Version als schlecht markieren (die ist eigentlich die "gute" Version, also invers denken).

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [master|BISECTING] $ git bisect bad
Nun die die noch gute Version markieren (also die eigentlich schlechte Version, git bisect funktioniert aber nur so herum).

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [master|BISECTING] $ git bisect good HEAD~15
Bisecting: 7 revisions left to test after this (roughly 3 steps)
[5bd3d5805cbb55a94ff4ae293e008d8852c7501f] libs: fix crash on record stop
Git sagt uns das es 9 (HEAD~15 + 7 = HEAD~8) Schritte in die Vergangenheit gegangen ist, nun müssen wir Git sagen ob diese Version good oder eben bad ist.

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [(5bd3d58...)|BISECTING] $ readelf -a libs/lib*.so | grep cRecord | grep GetStatus
   472: 000366d0    88 FUNC    GLOBAL DEFAULT   10 _ZN7cRecord9GetStatusEv
Symbol gefunden, also noch schlecht

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [(5bd3d58...)|BISECTING] $ git bisect bad
Bisecting: 3 revisions left to test after this (roughly 2 steps)
[fce3742a6c5f501654fc9912b815ef963190f1aa] testing/ dir with support for multi-record of the same channel
Git ist weitere 4 (insgesamt 13) Schritte in die Vergangenheit gegangen, wir stehen nun an Commit fce3742. Und wieder testet man ob das Symbol schon vorhanden ist.

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [(fce3742...)|BISECTING] $ readelf -a libs/lib*.so | grep cRecord | grep GetStatus
doc@wheezy:~/gitprojects/cst-public-drivers [(fce3742...)|BISECTING] $
Kein Symbol mehr gefunden, wir sind zu weit in der Vergangenheit, für Git ist diese Version good.

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [(fce3742...)|BISECTING] $ git bisect good
Bisecting: 1 revision left to test after this (roughly 1 step)
[3798bbc4704f3ce0afc21e2352c35c236831e1fa] restore stable libs
Git ist jetzt zur 11en Version in der Vergangenheit gesprungen und man muss wieder testen ob das Symbol schon vorhanden (bad) oder noch nicht vorhanden (good) ist.

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [(2.08)|BISECTING] $ readelf -a libs/lib*.so | grep cRecord | grep GetStatus
doc@wheezy:~/gitprojects/cst-public-drivers [(2.08)|BISECTING] $ git bisect good
Bisecting: 0 revisions left to test after this (roughly 0 steps)
[577d586f2b739d4508e9a071098478c0d16a501b] Update for image 2.09
Wieder nichts gefunden und Git ist zur Version zehn gesprungen, es verbleiben zwei Versionen die gut oder schlecht sein können.

Code: Alles auswählen

doc@wheezy:~/gitprojects/cst-public-drivers [(2.09)|BISECTING] $ readelf -a libs/lib*.so | grep cRecord | grep GetStatus
doc@wheezy:~/gitprojects/cst-public-drivers [(2.09)|BISECTING] $ git bisect good
5bd3d5805cbb55a94ff4ae293e008d8852c7501f is the first bad commit
commit 5bd3d5805cbb55a94ff4ae293e008d8852c7501f
Author: [CST] Focus <focus.cst@gmail.com>
Date:   Tue Sep 25 15:42:13 2012 +0400

    libs: fix crash on record stop

:040000 040000 5ad321b7541dcd4e28f65c9898be9a1a102c0d28 3242efd1c31dc335ba250aac67c60139a40182fe M      libs
git bisect sagt das es fertig ist, es steht nun an der 10 Version und teilt mit das dies der erste schlechte Commit war, die 9 Version wurde ja auch schon schlecht befunden. Das heißt in der 9en Version hatten wir das Symbol schon gefunden und in der 10en Version noch nicht. Nun wird es etwas schwierig, da wir aber invers gesucht haben und nun nicht Version 10 die erste Version war in der das gesuchte Symbol gefunden wurde sondern Version 9 muss man nun eben eine Version wieder in die Zukunft gehen (eben Version 9) um zu wissen ab wann ein Symbol eben vorhanden war.

Umgekehrt (und richtig) wird es wieder wenn wir ein Symbol suchen was es aber einer bestimmten Revision nicht mehr gab. Genau für solche Fälle, die Suche nach einer alten noch guten Revision wurde git bisect entwickelt.

Hier kann man auch wieder sehen warum richtige Commitmessages so wichtig sind! Man kann sich sonst wirklich einen absuchen, besonders bei diesen Binärsachen die nur sehr aufwendig zu durchsuchen sind.

Ups, ist was länger geworden.
Na schönen Dank Herr Schwanke!
Ein toller Sommer! :-(
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

also ...

ich habe jetzt die aktuellen cst-public-drivers über git ausgecheckt, libs und drivers von Hand reingefriemelt und nach langem hin und her hatte ich dann endlich ein fertiges flashroot-coolstream.img und ein passendes kernel.img ... viel trial and error, weil s an den Hintergründen fehlt ;) Hab das vorhin auf meine Coolstream Zee geflasht und .... läuft :D Auf den ersten Blick funktioniert alles wie es soll, Die externe HDD habe ich im laufenden Betrieb angesteckt, wurde da nicht erkannt. Nach einem Reboot war sie aber da. Aufnehmen und das Abspielen von Aufnahmen funktioniert ... mehr kann ich noch nicht sagen

Vielen Dank !!!
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Hi,

aktuell hängt bei mir der Build für Coolstream unter Archlinux und Ubuntu 12.04 in VM.

Code: Alles auswählen

 
  CXX    neutrino_menue.o
  CXX    neutrino.o
  CXXLD  neutrino
/home/flk/build/buildsystem-cs/cross/bin/../lib/gcc/arm-cx2450x-linux-gnueabi/4.7.1/../../../../arm-cx2450x-linux-gnueabi/bin/ld: cannot find -lca-sc
collect2: error: ld returned 1 exit status
edit: lag an zu alten libs

in make/environment.mk muss bei mir die Zeile einkommentiert werden:

#UNCOOL_LIBCA = $(UNCOOL_GIT)/cst-public-drivers/libs/libca-sc.so
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

nein, an zu neuen libs :-) Deine Lösung ist die richtige.
Funktioniert das gebaute denn auch?
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Nein, funktioniert so leider nicht. Neutrino startet, gibt aber kein Bild.
putty.log
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

hm, ich würde vermuten du hast evtl. nicht die neuesten Treiber:

cx24116_readreg: reg=0xff (error=-110)

cx24116_readreg: reg=0xfe (error=-110)

Das sieht evtl. nach einem Hardware- oder Treiberproblem aus.

Genaueres kann ich auch nicht sagen, wenn ich mal Zeit übrig habe suche ich mal eine Coolstream aus der Kiste und probiers aus... :-)
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Treiber müssten schon aktuell sein, die habe ich zusammen mit den libs mit git pull geholt.... jetzt gibts ja ein Target :)
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Danke, funktioniert wieder alles !
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

Hast du noch irgendwas gemacht oder hat es sich von selbst repariert?
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Unter Service > Kanalsuche > Tuner Setup steht der Tuner nicht mehr auf single sondern independent, obwohl ich nur eine Zee habe. Wahrscheinlich wegen dem PIP. Da kann ich auch nichts umstellen, ist grau. Dann ist mir aufgefallen, dass kein Satellit ausgewählt war -> auf Astra gestellt, und schon ist Bild da. :oops:
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Danke für die Updates, vor allem TVheadend :) Für Spark baut s problemlos durch, nur Coolstream macht wieder Ärger:

Code: Alles auswählen

 CXX    neutrino_menue.o
  CXX    neutrino.o
  CXXLD  neutrino
gui/libneutrino_gui.a(movieplayer.o): In function `CMoviePlayerGui::selectChapter()':
/home/flk/build/buildsystem-cs/source/neutrino-mp/src/gui/movieplayer.cpp:1266: undefined reference to `cPlayback::GetChapters(std::vector<int, std::allocator<int> >&, std::vector<std::string, std::allocator<std::string> >&)'
gui/libneutrino_gui.a(movieplayer.o): In function `CMoviePlayerGui::selectSubtitle()':
/home/flk/build/buildsystem-cs/source/neutrino-mp/src/gui/movieplayer.cpp:1299: undefined reference to `cPlayback::FindAllSubs(unsigned short*, unsigned short*, unsigned short*, std::string*)'
/home/flk/build/buildsystem-cs/source/neutrino-mp/src/gui/movieplayer.cpp:1325: undefined reference to `cPlayback::SelectSubtitles(int)'
/home/flk/build/buildsystem-cs/source/neutrino-mp/src/gui/movieplayer.cpp:1329: undefined reference to `cPlayback::SelectSubtitles(int)'
collect2: error: ld returned 1 exit status
make[4]: *** [neutrino] Fehler 1
make[4]: Verlasse Verzeichnis '/home/flk/build/buildsystem-cs/build_tmp/neutrino-mp/src'
make[3]: *** [all-recursive] Fehler 1
make[3]: Verlasse Verzeichnis '/home/flk/build/buildsystem-cs/build_tmp/neutrino-mp/src'
make[2]: *** [all-recursive] Fehler 1
make[2]: Verlasse Verzeichnis '/home/flk/build/buildsystem-cs/build_tmp/neutrino-mp'
make[1]: *** [all] Fehler 2
make[1]: Verlasse Verzeichnis '/home/flk/build/buildsystem-cs/build_tmp/neutrino-mp'
make: *** [neutrino-pkg] Fehler 2
flk@flk-VirtualBox:~/build/buildsystem-cs$ 
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

libs zu alt, würde ich sagen.
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

gibts da denn schon wieder neue :D

edit:

hattest Recht, wenn die libs an der richtigen Stelle liegen, klappts dann auch.
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Geht das nur mir so, oder ist bei anderen auch ein Image für Coolstream aus dem aktuellen Source unstabil ? Ich habe folgende Probleme:

- Nach Reboot startet Neutrino meistens mit zapit failed gefolgt von einem Neutrino Restart
- Meine Senderliste, die ich eigentlich immer verwende funktioniert nicht mehr. Ich muss zwingend einen Kanalsuchlauf machen
- nach erfolgreich beendetem Suchlauf fehlen z.B. Das Erste HD, ARTE HD ....
- Die Kiste bleibt beim Ausschalten hängen
- Nach Hardreset dann das bekannte Spiel, zapit failed, Neutrino Restart und mit Glück danach Bild, aber meistens ohne Uhrzeit und EPG Informationen
coolstream.log
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
seife
Developer
Beiträge: 4189
Registriert: Sonntag 2. November 2003, 12:36

Re: Neutrino-MP für Coolstream

Beitrag von seife »

beim ersten starten ist das frontend nicht da, deswegen crashed neutrino. Danach ist bis zum reboot alles kaputt (wenn immer ein Programm das die coolstream libs benutzt, sich nicht ordentlich beendet und selbst wieder alles schön aufräumt, ist bis zum Reboot die box kaputt. Weitere Versuche sind dann zwecklos).

Wenn du sicher bist, dass du die neueseten Treiber und libs benutzt, dann weiss ich auch nicht was das ist. Vorher kommt auch schon ein i2c-Fehler, evtl. könnte es also auch ein Hardwareproblem sein.
flk
Contributor
Beiträge: 293
Registriert: Donnerstag 21. November 2002, 05:32
Box 1: AX HD51
Image: tuxbox

Re: Neutrino-MP für Coolstream

Beitrag von flk »

Hi,
an ein Hardware Problem habe ich auch schon gedacht. Muss ich mir erst mal noch genauer anschauen.

Zurück zu „Buildsysteme allgemein“